$re = '/^(?!.*(?:notes|twitter)).*/m';
$str = 'lists/notes.json
lists/twitter.json
lists/books.json';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);