$re = '/^[-_a-zA-Z0-9.\']+(\s+[-_a-zA-Z0-9.\'_-]+)*$/';
$str = 'Ubahariya';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);