re = /^(([0-9A-Fa-f]{2}[:-]?){5}[0-9A-Fa-f]{2})-(([0-9A-Fa-f]{2}:?){4})$/
str = 'aa:aa:aa:aa:aa:aa-55:56:57:58:'
# Print the match result
str.match(re) do |match|
puts match.to_s
end