#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)([\d\.]+%) identity"
Local $sString = "# /data/spine/bin/external/fasta/bin/glsearch36 -b 2 -m 9i -q /tmp/temp.seq /data/spine/databases/UniProt/sprot.compact_headers.distinct.mouse" & @CRLF & _
"GLSEARCH performs a global-query/local-library search" & @CRLF & _
" version 36.3.6 Nov, 2013(preload9)" & @CRLF & _
"Query: /tmp/temp.seq" & @CRLF & _
" 1>>>seq - 299 aa" & @CRLF & _
"Library: /data/spine/databases/UniProt/sprot.compact_headers.distinct.mouse" & @CRLF & _
" 9277236 residues in 16315 sequences" & @CRLF & _
"" & @CRLF & _
"Statistics: Unscaled normal statistics: mu= -50.7059 var=2892.0306 Ztrim: 0" & @CRLF & _
" statistics sampled from 13365 (13367) to 13365 sequences" & @CRLF & _
"Algorithm: Global/Local affine Needleman-Wunsch (2007) (6.0 April 2007)" & @CRLF & _
"Parameters: BL50 matrix (15:-5), open/ext: -12/-2" & @CRLF & _
" Scan time: 11.560" & @CRLF & _
"" & @CRLF & _
"The best scores are: n-w bits E(16315) %_id %_sim alen" & @CRLF & _
"SP|P61375|LHX5_MOUSE ( 402) 1361 66.3 5.7e-148 0.685 0.868 302" & @CRLF & _
"SP|P50481|LHX3_MOUSE ( 400) 331 30.8 1e-08 0.319 0.524 307" & @CRLF & _
"" & @CRLF & _
">>>seq, 299 aa vs /data/spine/databases/UniProt/sprot.compact_headers.distinct.mouse library" & @CRLF & _
"" & @CRLF & _
">>SP|P61375|LHX5_MOUSE (402 aa)" & @CRLF & _
" n-w opt: 1361 Z-score: 312.5 bits: 66.3 E(16315): 5.7e-148" & @CRLF & _
"global/local score: 1361; 68.5% identity (86.8% similar) in 302 aa overlap (1-299:107-400)" & @CRLF & _
"" & @CRLF & _
" 10 20 30" & @CRLF & _
"seq YIDENKFVCKEDYLSNSSVAKENSLHSATT" & @CRLF & _
" :::::::::.::::.::. ::.::.:..." & @CRLF & _
"SP|P61 VRKARSKVFHLNCFTCMVCNKQLSTGEELYVIDENKFVCKDDYLSSSSL-KEGSLNSVSS" & @CRLF & _
" 80 90 100 110 120 130 " & @CRLF & _
"" & @CRLF & _
" 40 50 60 70 80 90" & @CRLF & _
"seq GSDPSLSPDSQDPSQDDAKDSESANVSDKEGGSNENDDQNLGAKRRGPRTTIKAKQLETL" & @CRLF & _
" .: ::::: ::: ::: :...... :::: ..:::..:: :.:::::::::::::::::" & @CRLF & _
"SP|P61 CTDRSLSPDLQDPLQDDPKETDNSTSSDKETANNENEEQNSGTKRRGPRTTIKAKQLETL" & @CRLF & _
" 140 150 160 170 180 190 " & @CRLF & _
"" & @CRLF & _
" 100 110 120 130 140 150" & @CRLF & _
"seq KAAFAATPKPTRHIREQLAQETGLNMRVIQVWFQNRRSKERRMKQLSALGARRHAFFRSP" & @CRLF & _
" ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::" & @CRLF & _
"SP|P61 KAAFAATPKPTRHIREQLAQETGLNMRVIQVWFQNRRSKERRMKQLSALGARRHAFFRSP" & @CRLF & _
" 200 210 220 230 240 250 " & @CRLF & _
"" & @CRLF & _
" 160 170 180 190 200 210" & @CRLF & _
"seq RRMRPLVDRLEPGELIPNGPFSFYGDYQSEYYGPGGNYDFFPQGPPSSQAQTPVDLPFVP" & @CRLF & _
" :::::: ::. .:.. . :...::::::.::.:::::::: .:::: :::.:.: :. " & @CRLF & _
"SP|P61 RRMRPLGGRLDESEMLGSTPYTYYGDYQSDYYAPGGNYDFFAHGPPS-QAQSPADSSFLA" & @CRLF & _
" 260 270 280 290 300 310 " & @CRLF & _
"" & @CRLF & _
" 220 230 240 250 260 " & @CRLF & _
"seq SSGPSGTPLGGLDHPLPGHHPSSEAQRFTDILAHPPGDSPSPEPSLPGPLHSMSAEVF--" & @CRLF & _
" .:::..::::.:. :: : : ... ::::...:: :.:::::.::: :: : .::: " & @CRLF & _
"SP|P61 ASGPGSTPLGALEPPLAGPH-GADNPRFTDMISHP--DTPSPEPGLPGALHPMPGEVFSG" & @CRLF & _
" 320 330 340 350 360 370 " & @CRLF & _
"" & @CRLF & _
" 270 280 290 " & @CRLF & _
"seq GPSPPFSSLSVNGGASYGNHLSHP-PEMNEAA " & @CRLF & _
" :::::: ..: ..:.. :::: ::.:::: " & @CRLF & _
"SP|P61 GPSPPFP---MSGTSGYSGPLSHPNPELNEAAVW" & @CRLF & _
" 380 390 400 " & @CRLF & _
"" & @CRLF & _
">>SP|P50481|LHX3_MOUSE (400 aa)" & @CRLF & _
" n-w opt: 331 Z-score: 121.0 bits: 30.8 E(16315): 1e-08" & @CRLF & _
"global/local score: 331; 31.9% identity (52.4% similar) in 307 aa overlap (1-299:99-365)" & @CRLF & _
"" & @CRLF & _
" 10 20 " & @CRLF & _
"seq YIDENKFVCK-EDYLSN-SSVAKENSLHSA" & @CRLF & _
" : .. : . .:.. . : .. " & @CRLF & _
"SP|P50 AERCFSRGESVYCKDDFFKRFGTKCAACQLGIPPTQVVRRAQDFVYHLHCFACVVCKRQL" & @CRLF & _
" 70 80 90 100 110 120 " & @CRLF & _
"" & @CRLF & _
" 30 40 50 60 70 80 " & @CRLF & _
"seq TTGSDPSLSPDSQDPSQDDAKDSESANVSDKEGGSNENDDQNLGAKRRGPRTTIKAKQLE" & @CRLF & _
" .::.. : ::. . : :.:. . :. ::: ::::: :::::" & @CRLF & _
"SP|P50 ATGDEFYLMEDSRLVCK---ADYETAKQREAEAT----------AKR--PRTTITAKQLE" & @CRLF & _
" 130 140 150 160 170 " & @CRLF & _
"" & @CRLF & _
" 90 100 110 120 130 140 " & @CRLF & _
"seq TLKAAFAATPKPTRHIREQLAQETGLNMRVIQVWFQNRRSKERRMKQLSALGARRHAFFR" & @CRLF & _
" :::.:. ..:::.::.::::..::::.:::.::::::::.::.:.:. .: : .::" & @CRLF & _
"SP|P50 TLKSAYNTSPKPARHVREQLSSETGLDMRVVQVWFQNRRAKEKRLKK-DAGRQRWGQYFR" & @CRLF & _
" 180 190 200 210 220 230 " & @CRLF & _
"" & @CRLF & _
" 150 160 170 180 190 200 " & @CRLF & _
"seq SPRRMRPLVDRLEPGELIPNGPFSFYGDYQSEYYGPGGNYDFFPQGPPSSQAQTPVDLPF" & @CRLF & _
" . .: : : .: .: : .. . :: . :.. ." & @CRLF & _
"SP|P50 NMKRSRG----------------SSKSDKDSIQEGQDSDAEVSFTDEPSMADMGPANGLY" & @CRLF & _
" 240 250 260 270 " & @CRLF & _
"" & @CRLF & _
" 210 220 230 240 250 260 " & @CRLF & _
"seq VPSSGPS---GTPLGGLDHPLPGHHPSSEAQRFTDILAHPP-GDSPSPEP--SLPGPLHS" & @CRLF & _
" . :. : :.::: : . ... .. : : ::: ::::: " & @CRLF & _
"SP|P50 SSLGEPAPALGRPVGGLGSFTLDHGGLTGPEQYRELRPGSPYGIPPSPAAPQSLPGPQPL" & @CRLF & _
" 280 290 300 310 320 330 " & @CRLF & _
"" & @CRLF & _
" 270 280 290 " & @CRLF & _
"seq MSAEVFGPSPPFSSLSVNGGASYGNHLSHPPEMNEAA " & @CRLF & _
" .:. :. : ..::. .. :. :: : : " & @CRLF & _
"SP|P50 LSSLVY----PDTNLSLVPSGPPGG----PPPMRVLAGNGPSSDLSTESSSGYPDFPASP" & @CRLF & _
" 340 350 360 370 380 " & @CRLF & _
"" & @CRLF & _
"SP|P50 ASWLDEVDHAQF" & @CRLF & _
" 390 400" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
">>>///" & @CRLF & _
"" & @CRLF & _
"299 residues in 1 query sequences" & @CRLF & _
"9277236 residues in 16315 library sequences" & @CRLF & _
" Tcomplib [36.3.6 Nov, 2013(preload9)] (8 proc in memory [0G])" & @CRLF & _
" start: Thu Sep 3 20:44:48 2015 done: Thu Sep 3 20:44:55 2015" & @CRLF & _
" Total Scan time: 11.560 Total Display time: 0.010" & @CRLF & _
"" & @CRLF & _
"Function used was GLSEARCH [36.3.6 Nov, 2013(preload9)]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")