$re = '/^[a-z0-9](?!.*--)[a-z0-9-]{1,61}[a-z0-9]$/m';
$str = 'test--test
test-test
tes11t-test111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);