package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B@\w+`)
var str = `The @dog went to the park.
But not here: The d@og went to the park.
Or here: The@dog went to the park.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}