package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([mwf]|th?|su?)`)
var str = `mwftthssu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}