re = /^(?:(?!Windows Phone).)*(iPhone|iPad|iPod)/i
str = 'Mozilla/5.0 like (Mobile; Windows Phone 8.1; Android 4.0; ARM; Trident/7.0 Touch; rv:11.0; IEMobile/11.0; NOKIA; Lumia 925) iPhone OS 7_0_3 Mac OS X AppleWebkit/537 (KHTML, like Gecko) Mobile Safari/537'
# Print the match result
str.match(re) do |match|
puts match.to_s
end