use strict;
my $str = 'foo...///bb""';
my $regex = qr/(\W)\1+/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";