# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\()(.*)(type=\'date\')(.*)"
test_str = (".form-group\n"
" label(for='title_event') #{__(\"entity.event.title_event\")} (*)\n"
" input.form-control.input(name='title_event', type='text', placeholder='#{__(\"entity.event.title_event\")}', autofocus, required)\n\n"
".form-group\n"
" label(for='typeevent_event') #{__(\"entity.event.typeevent_event\")}\n"
" input.form-control.input(name='typeevent_event', type='text', placeholder='#{__(\"entity.event.typeevent_event\")}')\n\n"
".row\n"
" .col-xs-4\n"
" .form-group\n"
" label(for='startdate_event') #{__(\"entity.event.startdate_event\")} (*)\n"
" .input-group\n"
" .input-group-addon\n"
" i.fa.fa-calendar\n"
" input.form-control.input(name='startdate_event', type='date', placeholder='#{__(\"entity.event.startdate_event\")}', required)\n"
" .col-xs-4\n"
" .form-group\n"
" label(for='enddate_event') #{__(\"entity.event.enddate_event\")} (*)\n"
" .input-group\n"
" .input-group-addon\n"
" i.fa.fa-calendar\n"
" input.form-control.input(name='enddate_event', type='date', placeholder='#{__(\"entity.event.enddate_event\")}', value='#{moment(\"entity.event.enddate_event\")}', required)\n"
"// .form-group\n"
"// label(for='starttime_event') #{__(\"entity.event.starttime_event\")}\n"
"// input.form-control.input(name='starttime_event', type='text', placeholder='#{__(\"entity.event.starttime_event\")}')\n"
".row\n"
" .col-xs-4\n"
" .form-group\n"
" label(for='starttime_event') #{__(\"entity.event.starttime_event\")}\n"
" span\n"
" .bootstrap-timepicker\n"
" .form-group\n"
" .input-group\n"
" input.form-control.timepicker(name='starttime_event', type='text')\n"
" .input-group-addon\n"
" i.fa.fa-clock-o\n"
".row\n"
" .col-xs-4\n"
" .form-group\n"
" label(for='endtime_event') #{__(\"entity.event.endtime_event\")}\n"
" // input.form-control.input(name='endtime_event', type='text', placeholder='#{__(\"entity.event.endtime_event\")}')\n"
" span\n"
" .bootstrap-timepicker\n"
" .form-group\n"
" .input-group\n"
" input.form-control.timepicker(name='endtime_event', type='text')\n"
" .input-group-addon\n"
" i.fa.fa-clock-o\n"
".form-group\n"
" input.form-control.input(name='allday_event', type='checkbox', placeholder='#{__(\"entity.event.allday_event\")}')\n"
" \n"
" label(for='allday_event') #{__(\"entity.event.allday_event\")}\n"
".form-group\n"
" label(for='location_event') #{__(\"entity.event.location_event\")}\n"
" input.form-control.input(name='location_event', type='text', placeholder='#{__(\"entity.event.location_event\")}')\n"
".form-group\n"
" label(for='participationmode_event') #{__(\"entity.event.participationmode_event\")}\n"
" input.form-control.input(name='participationmode_event', type='text', placeholder='#{__(\"entity.event.participationmode_event\")}')\n\n"
".form-group\n"
" label(for='description_event') #{__(\"entity.event.description_event\")}\n"
" input.form-control.input(name='description_event', type='text', placeholder='#{__(\"entity.event.description_event\")}')\n"
".form-group\n"
" label(for='color_event') #{__(\"entity.event.color_event\")}\n"
" // input.form-control.input(name='color_event', type='text', placeholder='#{__(\"entity.event.color_event\")}')\n"
" input.form-control.my-colorpicker1(name='color_event', type='text', placeholder='#{__(\"entity.event.color_event\")}')\n"
".form-group\n"
" label(for='owner_event') #{__(\"entity.event.owner_event\")}\n"
" input.form-control.input(name='owner_event', type='text', placeholder='#{__(\"entity.event.owner_event\")}')\n"
"// *** Dynamic Data Field Create Form Group event | Do not remove ***\n\n\n\n"
"//- .form-group\n"
"//- label(for='name_plateau') #{__(\"entity.plateau.name_plateau\")} (*)\n"
"//- input.form-control.input(name='name_plateau', type='text', placeholder='#{__(\"entity.plateau.name_plateau\")}',required)\n")
subst = ".datepicker$1$2type='text'$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.