import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]+[a-z]{0,2}(\\s\\((IV|V?I{0,3})\\))?$";
final String string = "1\n"
+ "2\n"
+ "3\n"
+ "4\n"
+ "5\n"
+ "6\n"
+ "7\n"
+ "8\n"
+ "8a\n"
+ "8b\n"
+ "8c\n"
+ "8d\n"
+ "8e\n"
+ "8f\n"
+ "8g\n"
+ "8h\n"
+ "9\n"
+ "10\n"
+ "11\n"
+ "12\n"
+ "13\n"
+ "14\n"
+ "15\n"
+ "16\n"
+ "17\n"
+ "17a\n"
+ "17b\n"
+ "17c\n"
+ "18\n"
+ "19\n"
+ "20\n"
+ "21\n"
+ "22\n"
+ "23 (I)\n"
+ "23 (II)\n"
+ "24\n"
+ "24a\n"
+ "24b\n"
+ "24c\n"
+ "25\n"
+ "26\n"
+ "27\n"
+ "28\n"
+ "30\n"
+ "31 (I)\n"
+ "31 (II)\n"
+ "32\n"
+ "33\n"
+ "34\n"
+ "34a\n"
+ "34b\n"
+ "34c\n"
+ "34d\n"
+ "34e\n"
+ "34f\n"
+ "34g\n"
+ "34h\n"
+ "34i\n"
+ "34j\n"
+ "34k\n"
+ "35\n"
+ "36\n"
+ "37\n"
+ "38\n"
+ "39\n"
+ "40\n"
+ "41\n"
+ "42\n"
+ "43\n"
+ "43a\n"
+ "43b\n"
+ "44 (I)\n"
+ "44 (II)\n"
+ "45\n"
+ "46\n"
+ "47\n"
+ "48\n"
+ "49\n"
+ "50\n"
+ "51\n"
+ "52\n"
+ "53\n"
+ "54\n"
+ "55\n"
+ "56\n"
+ "57\n"
+ "58\n"
+ "59a\n"
+ "59b\n"
+ "59c\n"
+ "59d\n"
+ "60\n"
+ "61\n"
+ "62\n"
+ "63\n"
+ "64\n"
+ "65\n"
+ "66\n"
+ "67\n"
+ "67c\n"
+ "68\n"
+ "69\n"
+ "70\n"
+ "71\n"
+ "72\n"
+ "73\n"
+ "74\n"
+ "75\n"
+ "76\n"
+ "76a\n"
+ "77\n"
+ "78\n"
+ "79\n"
+ "80\n"
+ "81\n"
+ "82\n"
+ "83\n"
+ "84\n"
+ "84a\n"
+ "84b\n"
+ "85\n"
+ "86\n"
+ "86a\n"
+ "87\n"
+ "89\n"
+ "89a\n"
+ "90\n"
+ "91\n"
+ "91a\n"
+ "91b\n"
+ "92\n"
+ "93\n"
+ "94\n"
+ "95\n"
+ "96\n"
+ "96a\n"
+ "97\n"
+ "98\n"
+ "99\n"
+ "100\n"
+ "101\n"
+ "102\n"
+ "103\n"
+ "104\n"
+ "105\n"
+ "106\n"
+ "106a\n"
+ "106b\n"
+ "106c\n"
+ "106d\n"
+ "106e\n"
+ "106f\n"
+ "107\n"
+ "108\n"
+ "109\n"
+ "110\n"
+ "111\n"
+ "112\n"
+ "113\n"
+ "114\n"
+ "115\n"
+ "116\n"
+ "117\n"
+ "118\n"
+ "119\n"
+ "120\n"
+ "121\n"
+ "122\n"
+ "125\n"
+ "126\n"
+ "127\n"
+ "128\n"
+ "129\n"
+ "130\n"
+ "131\n"
+ "132\n"
+ "133\n"
+ "134\n"
+ "135\n"
+ "136 (I)\n"
+ "136 (II)\n"
+ "136 (III)\n"
+ "136 (IV)\n"
+ "136 (V)\n"
+ "136 (VI)\n"
+ "136b\n"
+ "137\n"
+ "138\n"
+ "138a\n"
+ "138b\n"
+ "138c\n"
+ "138d\n"
+ "138e\n"
+ "139\n"
+ "140\n"
+ "141\n"
+ "142\n"
+ "142a\n"
+ "142b\n"
+ "142c\n"
+ "142d\n"
+ "143\n"
+ "144\n"
+ "145\n"
+ "146\n"
+ "147\n"
+ "147a\n"
+ "147b\n"
+ "147c\n"
+ "147d\n"
+ "147e\n"
+ "148\n"
+ "149\n"
+ "150\n"
+ "150a\n"
+ "151\n"
+ "151a\n"
+ "151b\n"
+ "151c\n"
+ "151d\n"
+ "152\n"
+ "153\n"
+ "154\n"
+ "154a\n"
+ "154b\n"
+ "155\n"
+ "156\n"
+ "157\n"
+ "158\n"
+ "159\n"
+ "160\n"
+ "161\n"
+ "162\n"
+ "162b\n"
+ "162c\n"
+ "163 (I)\n"
+ "163 (II)\n"
+ "164\n"
+ "165\n"
+ "166\n"
+ "167\n"
+ "167a\n"
+ "167b\n"
+ "168\n"
+ "169\n"
+ "170\n"
+ "171\n"
+ "172\n"
+ "173\n"
+ "174\n"
+ "175 (I)\n"
+ "175 (II)\n"
+ "176\n"
+ "177\n"
+ "178\n"
+ "179\n"
+ "180\n"
+ "181 (I)\n"
+ "181 (II)\n"
+ "182\n"
+ "183\n"
+ "184\n"
+ "185\n"
+ "186\n"
+ "187\n"
+ "188\n"
+ "189\n"
+ "190\n"
+ "191\n"
+ "192\n"
+ "193\n"
+ "194\n"
+ "195\n"
+ "196\n"
+ "197\n"
+ "198\n"
+ "199\n"
+ "200\n"
+ "201\n"
+ "202\n"
+ "203\n"
+ "204\n"
+ "205\n"
+ "206\n"
+ "207\n"
+ "208\n"
+ "209\n"
+ "210\n"
+ "211\n"
+ "212\n"
+ "213\n"
+ "214\n"
+ "215\n"
+ "217\n"
+ "218\n"
+ "219\n"
+ "220\n"
+ "221\n"
+ "222\n"
+ "223\n"
+ "224\n"
+ "225\n"
+ "226\n"
+ "227\n"
+ "228\n"
+ "229\n"
+ "230\n"
+ "231\n"
+ "232\n"
+ "233\n"
+ "234\n"
+ "235\n"
+ "236\n"
+ "237\n"
+ "238\n"
+ "239\n"
+ "240\n"
+ "241\n"
+ "242\n"
+ "243\n"
+ "244\n"
+ "245\n"
+ "246\n"
+ "247\n"
+ "248\n"
+ "249\n"
+ "250\n"
+ "251\n"
+ "252\n"
+ "253\n"
+ "254\n"
+ "255 (I)\n"
+ "255 (II)\n"
+ "255 (IV)\n"
+ "256\n"
+ "256a\n"
+ "256b\n"
+ "256c\n"
+ "256e\n"
+ "256f\n"
+ "256g\n"
+ "256h\n"
+ "256i\n"
+ "256j (I)\n"
+ "256j (II)\n"
+ "256k\n"
+ "256l\n"
+ "256m\n"
+ "256n\n"
+ "256o\n"
+ "256q\n"
+ "256r\n"
+ "256s\n"
+ "256t\n"
+ "256u\n"
+ "256v\n"
+ "256w\n"
+ "256x\n"
+ "256y\n"
+ "256aa\n"
+ "256ab\n"
+ "256ac\n"
+ "256ad\n"
+ "256ae\n"
+ "256af\n"
+ "256ag\n"
+ "256ah\n"
+ "256ai\n"
+ "256aj\n"
+ "256ak\n"
+ "256al\n"
+ "256am\n"
+ "256an\n"
+ "256ao\n"
+ "256ap\n"
+ "256aq\n"
+ "256ar\n"
+ "256as\n"
+ "257a\n"
+ "257b\n"
+ "257c\n"
+ "258\n"
+ "259\n"
+ "260\n"
+ "261\n"
+ "262\n"
+ "263\n"
+ "264\n"
+ "265\n"
+ "265a\n"
+ "266\n"
+ "267\n"
+ "267a\n"
+ "267b\n"
+ "267c\n"
+ "267d\n"
+ "268\n"
+ "269\n"
+ "270\n"
+ "270a\n"
+ "270b\n"
+ "270c\n"
+ "271\n"
+ "272\n"
+ "273\n"
+ "274\n"
+ "275\n"
+ "276\n"
+ "277\n"
+ "277a\n"
+ "277b\n"
+ "278\n"
+ "279\n"
+ "280\n"
+ "281\n"
+ "282\n"
+ "283\n"
+ "284\n"
+ "285 (I)\n"
+ "285 (II)\n"
+ "286\n"
+ "287\n"
+ "288\n"
+ "290\n"
+ "291\n"
+ "292\n"
+ "293\n"
+ "294\n"
+ "295\n"
+ "296 (I)\n"
+ "296 (II)\n"
+ "296 (III)\n"
+ "297\n"
+ "298 (I)\n"
+ "298 (II)\n"
+ "299\n"
+ "300\n"
+ "301\n"
+ "303\n"
+ "304\n"
+ "305\n"
+ "306\n"
+ "307\n"
+ "308\n"
+ "309\n"
+ "310\n"
+ "311\n"
+ "312 (I)\n"
+ "312 (II)\n"
+ "313\n"
+ "314\n"
+ "315\n"
+ "316\n"
+ "317\n"
+ "319\n"
+ "320\n"
+ "321\n"
+ "322\n"
+ "323\n"
+ "324\n"
+ "324a\n"
+ "324b\n"
+ "324c\n"
+ "324d\n"
+ "324e\n"
+ "324g\n"
+ "324h\n"
+ "324i\n"
+ "324j\n"
+ "324k\n"
+ "324l\n"
+ "325\n"
+ "326\n"
+ "327\n"
+ "328\n"
+ "329\n"
+ "330\n"
+ "331\n"
+ "332\n"
+ "333\n"
+ "334\n"
+ "335\n"
+ "336\n"
+ "337\n"
+ "338\n"
+ "338a\n"
+ "338b\n"
+ "338c\n"
+ "339\n"
+ "340\n"
+ "341\n"
+ "341a\n"
+ "342\n"
+ "342a\n"
+ "343 (I)\n"
+ "343 (II)\n"
+ "344\n"
+ "345\n"
+ "345a\n"
+ "345b\n"
+ "345c\n"
+ "345d\n"
+ "345e\n"
+ "346\n"
+ "347\n"
+ "348\n"
+ "349\n"
+ "350\n"
+ "351\n"
+ "352\n"
+ "353\n"
+ "354\n"
+ "355\n"
+ "355a\n"
+ "355b\n"
+ "356\n"
+ "356a\n"
+ "356b\n"
+ "356c\n"
+ "358\n"
+ "358a\n"
+ "358b\n"
+ "359\n"
+ "360\n"
+ "360a\n"
+ "361\n"
+ "362\n"
+ "363\n"
+ "364\n"
+ "365\n"
+ "366\n"
+ "367\n"
+ "368\n"
+ "369\n"
+ "370\n"
+ "371\n"
+ "372\n"
+ "373\n"
+ "374\n"
+ "375\n"
+ "375a\n"
+ "375b\n"
+ "375c\n"
+ "376\n"
+ "377\n"
+ "378\n"
+ "379\n"
+ "380\n"
+ "381\n"
+ "382\n"
+ "383\n"
+ "384\n"
+ "384a\n"
+ "384b\n"
+ "384d\n"
+ "384e\n"
+ "384f\n"
+ "385\n"
+ "386\n"
+ "386a\n"
+ "386b\n"
+ "386c\n"
+ "386d\n"
+ "386e\n"
+ "387\n"
+ "388\n"
+ "389\n"
+ "390\n"
+ "391\n"
+ "392\n"
+ "393\n"
+ "394\n"
+ "395\n"
+ "396\n"
+ "397\n"
+ "398\n"
+ "399\n"
+ "400\n"
+ "401\n"
+ "402\n"
+ "403\n"
+ "404\n"
+ "405\n"
+ "406\n"
+ "407\n"
+ "408\n"
+ "409 (I)\n"
+ "409 (II)\n"
+ "409 (III)\n"
+ "410 (I)\n"
+ "410 (II)\n"
+ "411\n"
+ "412\n"
+ "413\n"
+ "414\n"
+ "415\n"
+ "416\n"
+ "417 (I)\n"
+ "417 (II)\n"
+ "418\n"
+ "419\n"
+ "420\n"
+ "421\n"
+ "422\n"
+ "422a\n"
+ "422b (I)\n"
+ "422b (II)\n"
+ "422c\n"
+ "423\n"
+ "424\n"
+ "424a\n"
+ "425\n"
+ "426\n"
+ "427\n"
+ "428\n"
+ "429 (I)\n"
+ "429 (II)\n"
+ "430\n"
+ "431\n"
+ "432\n"
+ "433\n"
+ "434\n"
+ "435\n"
+ "435a\n"
+ "436\n"
+ "437\n"
+ "438\n"
+ "439\n"
+ "440 (I)\n"
+ "440 (II)\n"
+ "440 (III)\n"
+ "440 (IV)\n"
+ "441\n"
+ "442\n"
+ "443 (I)\n"
+ "443 (II)\n"
+ "444\n"
+ "445\n"
+ "446\n"
+ "447\n"
+ "448 (I)\n"
+ "448 (II)\n"
+ "449\n"
+ "450\n"
+ "451\n"
+ "452\n"
+ "453\n"
+ "454\n"
+ "455\n"
+ "456\n"
+ "457\n"
+ "458\n"
+ "459\n"
+ "460\n"
+ "461\n"
+ "462\n"
+ "463\n"
+ "464\n"
+ "465\n"
+ "466\n"
+ "467\n"
+ "468\n"
+ "469\n"
+ "470\n"
+ "471\n"
+ "472\n"
+ "473\n"
+ "474\n"
+ "475\n"
+ "476\n"
+ "477\n"
+ "478\n"
+ "479\n"
+ "480\n"
+ "481\n"
+ "482\n"
+ "483\n"
+ "484\n"
+ "485\n"
+ "486\n"
+ "487\n"
+ "488\n"
+ "489\n"
+ "490\n"
+ "491\n"
+ "492\n"
+ "493\n"
+ "494\n"
+ "495\n"
+ "496\n"
+ "497\n"
+ "498\n"
+ "499\n"
+ "500\n"
+ "501\n"
+ "502 (I)\n"
+ "502 (II)\n"
+ "503\n"
+ "504\n"
+ "505\n"
+ "506\n"
+ "507\n"
+ "508\n"
+ "509\n"
+ "510\n"
+ "511\n"
+ "513\n"
+ "514\n"
+ "515 (I)\n"
+ "515 (II)\n"
+ "516\n"
+ "517\n"
+ "518\n"
+ "519\n"
+ "520\n"
+ "521\n"
+ "522\n"
+ "523\n"
+ "524\n"
+ "525\n"
+ "526\n"
+ "527\n"
+ "528\n"
+ "529\n"
+ "530\n"
+ "531\n"
+ "532\n"
+ "533\n"
+ "534\n"
+ "535\n"
+ "536\n"
+ "537\n"
+ "538\n"
+ "539\n"
+ "540\n"
+ "541\n"
+ "542\n"
+ "543\n"
+ "544\n"
+ "545\n"
+ "546\n"
+ "547\n"
+ "548\n"
+ "549\n"
+ "550\n"
+ "551\n"
+ "552\n"
+ "553\n"
+ "554\n"
+ "555\n"
+ "556\n"
+ "557\n"
+ "558\n"
+ "559\n"
+ "560\n"
+ "561\n"
+ "562\n"
+ "563\n"
+ "564\n"
+ "565\n"
+ "566\n"
+ "567\n"
+ "568\n"
+ "569\n"
+ "570\n"
+ "571\n"
+ "572\n"
+ "573\n"
+ "574\n"
+ "575\n"
+ "576\n"
+ "577\n"
+ "578\n"
+ "579\n"
+ "580\n"
+ "581\n"
+ "582\n"
+ "583 (I)\n"
+ "583 (II)\n"
+ "584\n"
+ "585\n"
+ "586\n"
+ "587\n"
+ "588\n"
+ "589\n"
+ "590\n"
+ "591\n"
+ "592\n"
+ "593\n"
+ "594\n"
+ "595\n"
+ "596\n"
+ "597\n"
+ "598\n"
+ "599\n"
+ "600 (I)\n"
+ "600 (II)\n"
+ "601\n"
+ "602\n"
+ "603 (I)\n"
+ "603 (II)\n"
+ "604\n"
+ "605 (I)\n"
+ "605 (II)\n"
+ "606\n"
+ "607\n"
+ "608 (I)\n"
+ "608 (II)\n"
+ "609\n"
+ "610\n"
+ "611\n"
+ "612\n"
+ "613 (I)\n"
+ "613 (II)\n"
+ "614 (I)\n"
+ "614 (II)\n"
+ "615\n"
+ "616\n"
+ "617\n"
+ "618\n"
+ "619\n"
+ "620\n"
+ "621\n"
+ "622\n"
+ "623\n"
+ "624\n"
+ "625\n"
+ "626\n"
+ "627\n"
+ "628\n"
+ "629\n"
+ "630\n"
+ "631\n"
+ "632\n"
+ "633\n"
+ "634\n"
+ "635\n"
+ "636\n"
+ "637\n"
+ "638\n"
+ "639\n"
+ "640\n"
+ "641\n"
+ "642\n"
+ "643\n"
+ "644\n"
+ "645\n"
+ "646\n"
+ "647\n"
+ "648\n"
+ "649\n"
+ "650\n"
+ "651\n"
+ "652\n"
+ "653\n"
+ "654\n"
+ "655\n"
+ "656\n"
+ "657\n"
+ "658\n"
+ "659\n"
+ "660\n"
+ "661\n"
+ "662\n"
+ "663\n"
+ "664\n"
+ "665\n"
+ "666\n"
+ "667\n"
+ "668\n"
+ "669\n"
+ "670\n"
+ "671\n"
+ "672\n"
+ "673\n"
+ "674\n"
+ "675\n"
+ "676\n"
+ "677\n"
+ "678\n"
+ "679\n"
+ "680\n"
+ "681\n"
+ "682\n"
+ "683\n"
+ "684\n"
+ "685\n"
+ "686\n"
+ "687\n"
+ "688\n"
+ "689\n"
+ "690\n"
+ "691\n"
+ "692\n"
+ "693\n"
+ "694\n"
+ "695\n"
+ "696 (I)\n"
+ "696 (II)\n"
+ "696 (III)\n"
+ "696 (IV)\n"
+ "696 (V)\n"
+ "696 (VI)\n"
+ "697\n"
+ "698\n"
+ "699\n"
+ "700\n"
+ "701\n"
+ "702 (I)\n"
+ "702 (II)\n"
+ "703\n"
+ "704\n"
+ "705\n"
+ "706\n"
+ "707\n"
+ "708 (I)\n"
+ "708 (II)\n"
+ "708 (III)\n"
+ "709\n"
+ "710\n"
+ "710a\n"
+ "710b\n"
+ "710c\n"
+ "710d\n"
+ "710e (I)\n"
+ "710e (II)\n"
+ "710f\n"
+ "710g\n"
+ "710h\n"
+ "710i\n"
+ "710j\n"
+ "710k\n"
+ "710l\n"
+ "710m\n"
+ "710n\n"
+ "710o\n"
+ "710p\n"
+ "710q\n"
+ "710r\n"
+ "710t\n"
+ "710u\n"
+ "710v\n"
+ "710w\n"
+ "710x\n"
+ "710y\n"
+ "710z\n"
+ "710aa\n"
+ "710ab\n"
+ "710ac\n"
+ "710ad\n"
+ "710ae\n"
+ "710af\n"
+ "710ag\n"
+ "710ah\n"
+ "710ai\n"
+ "710aj\n"
+ "710ak\n"
+ "710al\n"
+ "710am\n"
+ "710an\n"
+ "710ao\n"
+ "710ap\n"
+ "710aq\n"
+ "710ar\n"
+ "710as\n"
+ "710at\n"
+ "710au\n"
+ "710av\n"
+ "710aw\n"
+ "710ax\n"
+ "710ay\n"
+ "710az\n"
+ "710ba\n"
+ "710bb\n"
+ "710bc\n"
+ "710bd\n"
+ "710be\n"
+ "710bf\n"
+ "710bg\n"
+ "710bh\n"
+ "710bi\n"
+ "710bj\n"
+ "710bk\n"
+ "710bl\n"
+ "710bm\n"
+ "710bn\n"
+ "710bo\n"
+ "710bp\n"
+ "710bq\n"
+ "710br\n"
+ "710bs\n"
+ "710bt\n"
+ "710bu\n"
+ "710bv\n"
+ "710bw\n"
+ "710bx\n"
+ "710by\n"
+ "710bz\n"
+ "710ca\n"
+ "710cb\n"
+ "710cc\n"
+ "710cd\n"
+ "710ce\n"
+ "710cf\n"
+ "710cg\n"
+ "710ch\n"
+ "710ci\n"
+ "711\n"
+ "712\n"
+ "713\n"
+ "714\n"
+ "715\n"
+ "716\n"
+ "716a\n"
+ "716b\n"
+ "717\n"
+ "718\n"
+ "719\n"
+ "720\n"
+ "720a\n"
+ "720b\n"
+ "721\n"
+ "722 (I)\n"
+ "722 (II)\n"
+ "723\n"
+ "724\n"
+ "725 (I)\n"
+ "725 (II)\n"
+ "725 (III)\n"
+ "725 (IV)\n"
+ "726\n"
+ "727\n"
+ "728\n"
+ "729\n"
+ "730\n"
+ "731\n"
+ "732\n"
+ "733\n"
+ "734\n"
+ "735\n"
+ "736\n"
+ "737\n"
+ "738\n"
+ "739\n"
+ "739a\n"
+ "739c\n"
+ "739d\n"
+ "739e\n"
+ "739f\n"
+ "739g\n"
+ "740\n"
+ "741\n"
+ "742\n"
+ "743\n"
+ "744\n"
+ "745\n"
+ "746\n"
+ "747\n"
+ "748\n"
+ "749\n"
+ "750\n"
+ "751\n"
+ "752\n"
+ "753\n"
+ "754\n"
+ "755\n"
+ "756\n"
+ "757\n"
+ "758\n"
+ "759\n"
+ "760\n"
+ "761\n"
+ "762\n"
+ "763\n"
+ "764\n"
+ "765\n"
+ "766\n"
+ "767\n"
+ "768\n"
+ "769\n"
+ "770\n"
+ "771\n"
+ "772\n"
+ "773\n"
+ "774\n"
+ "774a\n"
+ "774b\n"
+ "774c\n"
+ "774d\n"
+ "774e\n"
+ "774f\n"
+ "774g\n"
+ "774h\n"
+ "774i\n"
+ "774j\n"
+ "774k\n"
+ "774w\n"
+ "774x\n"
+ "774y\n"
+ "774z\n"
+ "774aa\n"
+ "774ab\n"
+ "774ac\n"
+ "774ad\n"
+ "774ae\n"
+ "774af\n"
+ "774ag\n"
+ "774ah\n"
+ "774ai\n"
+ "775\n"
+ "776\n"
+ "777\n"
+ "778\n"
+ "779\n"
+ "779a\n"
+ "780\n"
+ "780a\n"
+ "781\n"
+ "782\n"
+ "783 (I)\n"
+ "783 (II)\n"
+ "783a\n"
+ "783b\n"
+ "784\n"
+ "785\n"
+ "786\n"
+ "787\n"
+ "787a\n"
+ "787b\n"
+ "788\n"
+ "788a\n"
+ "788b\n"
+ "789\n"
+ "790\n"
+ "790a\n"
+ "790b\n"
+ "791\n"
+ "792\n"
+ "793\n"
+ "794\n"
+ "795\n"
+ "796\n"
+ "797\n"
+ "798\n"
+ "799\n"
+ "800\n"
+ "802\n"
+ "803\n"
+ "804\n"
+ "805\n"
+ "806\n"
+ "807\n"
+ "808\n"
+ "810\n"
+ "812\n"
+ "813\n"
+ "814\n"
+ "815\n"
+ "816\n"
+ "817\n"
+ "818\n"
+ "819\n"
+ "820\n"
+ "821 (I)\n"
+ "821 (II)\n"
+ "821 (III)\n"
+ "822\n"
+ "823\n"
+ "824\n"
+ "825\n"
+ "826\n"
+ "827\n"
+ "828\n"
+ "829\n"
+ "830\n"
+ "831\n"
+ "832\n"
+ "833\n"
+ "834\n"
+ "835\n"
+ "836\n"
+ "836a\n"
+ "836b\n"
+ "836c\n"
+ "836d\n"
+ "836e\n"
+ "836f\n"
+ "836h\n"
+ "836i\n"
+ "836j\n"
+ "836k\n"
+ "836l\n"
+ "836m\n"
+ "836q\n"
+ "836r\n"
+ "836s\n"
+ "836t\n"
+ "836u\n"
+ "836v\n"
+ "836w\n"
+ "836x\n"
+ "836y\n"
+ "836z\n"
+ "837\n"
+ "838\n"
+ "839\n"
+ "840\n"
+ "841\n"
+ "842\n"
+ "843\n"
+ "844\n"
+ "845\n"
+ "845a\n"
+ "845b\n"
+ "845c\n"
+ "845d\n"
+ "846\n"
+ "847\n"
+ "848\n"
+ "848a\n"
+ "848b\n"
+ "848c\n"
+ "849\n"
+ "850\n"
+ "850a\n"
+ "850b\n"
+ "851\n"
+ "852\n"
+ "853\n"
+ "854\n"
+ "855\n"
+ "856\n"
+ "857\n"
+ "858\n"
+ "859\n"
+ "860\n"
+ "861\n"
+ "862\n"
+ "863\n"
+ "864\n"
+ "865\n"
+ "866\n"
+ "867\n"
+ "868\n"
+ "869\n"
+ "870\n"
+ "871\n"
+ "872\n"
+ "873\n"
+ "874\n"
+ "875\n"
+ "875a\n"
+ "875b\n"
+ "875c\n"
+ "875d\n"
+ "875e\n"
+ "875f\n"
+ "875g\n"
+ "875h\n"
+ "875i\n"
+ "875j\n"
+ "875k\n"
+ "875l\n"
+ "876\n"
+ "877\n"
+ "878\n"
+ "879\n"
+ "880\n"
+ "881\n"
+ "882\n"
+ "883 (I)\n"
+ "883 (II)\n"
+ "883a\n"
+ "883b\n"
+ "883c\n"
+ "884\n"
+ "885\n"
+ "886\n"
+ "887\n"
+ "888\n"
+ "889\n"
+ "890 (I)\n"
+ "890 (II)\n"
+ "891\n"
+ "892\n"
+ "893\n"
+ "894\n"
+ "895\n"
+ "896\n"
+ "897\n"
+ "898 (I)\n"
+ "898 (II)\n"
+ "899\n"
+ "900\n"
+ "901\n"
+ "902\n"
+ "903\n"
+ "904\n"
+ "905\n"
+ "906\n"
+ "907\n"
+ "908\n"
+ "909\n"
+ "910\n"
+ "911\n"
+ "912\n"
+ "913\n"
+ "914\n"
+ "915\n"
+ "916\n"
+ "917\n"
+ "918\n"
+ "919\n"
+ "920\n"
+ "921\n"
+ "922 (I)\n"
+ "922 (II)\n"
+ "923\n"
+ "924\n"
+ "925\n"
+ "926\n"
+ "927\n"
+ "928\n"
+ "929\n"
+ "930\n"
+ "931\n"
+ "932\n"
+ "933\n"
+ "934\n"
+ "935\n"
+ "936\n"
+ "937\n"
+ "938\n"
+ "939\n"
+ "940\n"
+ "941\n"
+ "942\n"
+ "943\n"
+ "944\n"
+ "945\n"
+ "946\n"
+ "947\n"
+ "948\n"
+ "949\n"
+ "950\n"
+ "951\n"
+ "952\n"
+ "953\n"
+ "954\n"
+ "955\n"
+ "956\n"
+ "957\n"
+ "957a\n"
+ "957d\n"
+ "957e\n"
+ "957f\n"
+ "957h\n"
+ "957i (I)\n"
+ "957i (II)\n"
+ "958\n"
+ "959\n"
+ "960\n"
+ "961\n"
+ "963\n"
+ "964\n"
+ "965\n"
+ "966\n"
+ "967\n"
+ "968\n"
+ "969\n"
+ "970\n"
+ "971\n"
+ "972\n"
+ "973\n"
+ "974\n"
+ "975\n"
+ "976\n"
+ "977\n"
+ "977a\n"
+ "977b\n"
+ "977c\n"
+ "977d\n"
+ "977e\n"
+ "977f\n"
+ "977g\n"
+ "977h\n"
+ "978\n"
+ "979\n"
+ "980\n"
+ "981\n"
+ "982\n"
+ "983\n"
+ "984\n"
+ "985\n"
+ "986\n"
+ "987\n"
+ "988\n"
+ "989\n"
+ "990\n"
+ "991\n"
+ "992\n"
+ "993\n"
+ "994\n"
+ "995\n"
+ "996\n"
+ "997\n"
+ "998 (I)\n"
+ "998 (II)\n"
+ "998 (III)\n"
+ "999\n"
+ "999a\n"
+ "1000\n"
+ "1001\n"
+ "1002\n"
+ "1003\n"
+ "1004\n"
+ "1005\n"
+ "1006\n"
+ "1007\n"
+ "1008\n"
+ "1009\n"
+ "1010\n"
+ "1011\n"
+ "1012\n"
+ "1013\n"
+ "1014\n"
+ "1015\n"
+ "1016\n"
+ "1017\n"
+ "1018\n"
+ "1019\n"
+ "1019a\n"
+ "1019b\n"
+ "1019c\n"
+ "1019d\n"
+ "1019e\n"
+ "1019f\n"
+ "1019g\n"
+ "1019h\n"
+ "1019i\n"
+ "1019j\n"
+ "1020\n"
+ "1021\n"
+ "1022\n"
+ "1022a\n"
+ "1023\n"
+ "1024\n"
+ "1026\n"
+ "1027\n"
+ "1028\n"
+ "1029\n"
+ "1030\n"
+ "1031\n"
+ "1032\n"
+ "1033\n"
+ "1034\n"
+ "1035\n"
+ "1036\n"
+ "1037\n"
+ "1038\n"
+ "1039\n"
+ "1040\n"
+ "1041\n"
+ "1042\n"
+ "1043\n"
+ "1044\n"
+ "1045\n"
+ "1046\n"
+ "1047\n"
+ "1048\n"
+ "1049\n"
+ "1050\n"
+ "1051\n"
+ "1053\n"
+ "1054\n"
+ "1055\n"
+ "1056\n"
+ "1057\n"
+ "1058\n"
+ "1059\n"
+ "1060\n"
+ "1060a\n"
+ "1060b\n"
+ "1063\n"
+ "1063a\n"
+ "1064\n"
+ "1065\n"
+ "1066\n"
+ "1067\n"
+ "1068\n"
+ "1069\n"
+ "1070\n"
+ "1071\n"
+ "1072\n"
+ "1072a\n"
+ "1073\n"
+ "1074\n"
+ "1075\n"
+ "1076\n"
+ "1077\n"
+ "1078\n"
+ "1079\n"
+ "1080\n"
+ "1082\n"
+ "1083\n"
+ "1084\n"
+ "1085\n"
+ "1086\n"
+ "1087\n"
+ "1088\n"
+ "1089\n"
+ "1090\n"
+ "1091\n"
+ "1092\n"
+ "1093\n"
+ "1094\n"
+ "1095\n"
+ "1096\n"
+ "1097\n"
+ "1098\n"
+ "1099\n"
+ "1100\n"
+ "1101\n"
+ "1102\n"
+ "1103\n"
+ "1104\n"
+ "1105\n"
+ "1106\n"
+ "1107";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}