$re = '/\b(?i)([a-z]{2}\d{10})|([a-z]{3}[0-9]{1}[0-9a-z]{9})|([a-z]{2}[0-9]{1}[0-9a-z]{9})|([a-z]{3}[0-9]{1}[0-9a-z]{8})|([a-z]{2}\-\d{9}\-\d)|([a-z]{2}\-[0-9]{1}[0-9a-z]{8}\-\d)|([a-z]{3}\-[0-9]{1}[0-9a-z]{7}\-\d)/m';
$str = 'ISIN: US5949181045
Title: Microsoft Corp.
Description: Equity, ISIN US5949181045, WKN 870747, MSF
US-594918104-5
ISIN: US38259P5089
Title: Google Inc.
Description: Equity, ISIN US38259P5089, WKN A0B7FY, GGQ1
Country: US
US-38259P508-9
ISIN: US0378331005
Title: Apple Inc.
Description: Equity, ISIN US0378331005, WKN 865985, APC
Country: US
US-037833100-5
ISIN: BMG491BT1088
Title: INVESCO LTD DL -,10
Description: Equity, ISIN BMG491BT1088, WKN A0M6U7, 3IW
Country: Bermuda
BMG-491BT108-8
ISIN: IE00B4BNMY34
Title: ACCENTURE PLC A DL-000025
Description: Equity, ISIN IE00B4BNMY34, WKN A0YAQA, CSA
Country: Ireland
IE-00B4BNMY3-4
ISIN: DE000CM7VX13
Title: Aktienanleihe Plus auf
Description: Investment Product, ISIN DE000CM7VX13, WKN
Country: Germany
DE-000CM7VX1-3
ISIN: US30303M1027
Title: Facebook, Inc.
Description: Equity Shares, ISIN US30303M1027
Country: United States
US-30303M102-7
ISIN: CH0031240127
Title: BMW Australia
Description: Bond, ISIN CH0031240127, WKN A0NWXQ
Country: Switzerland
CH-003124012-7
ISIN: CA9861913023
Title: Yorbeau Res Inc.
Description: Equity, ISIN CA9861913023, WKN 872300, UAN
Country: Canada
CH-003124012-7
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);