$re = '/^(?!.*-$)(?!-)[a-z0-9-]{1,63}$/m';
$str = 'fgdghd
-fdgdf
dfgfg-
fdd-df
230sdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);