re = /[^!?。\.\!\?]+[!?。\.\!\?]?/
str = '热带风暴尚塔尔是2001年大西洋飓风季的一场在8月穿越了加勒比海的北大西洋热带气旋。尚塔尔于8月14日由热带大西洋的一股东风波发展而成,其存在的大部分时间里都在快速向西移动,退化成东风波后穿越了向风群岛。'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end