$re = '/(?<!Cold\s|Hot\s)Water/m';
$str = 'This is Cold Water and this is Hot Water, have some Water';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);