using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.+[:]{2}|(?:.*?\\{2})+)?(.*)\Z";
string input = @"SwHawk\\ProgressEvolutionOfTechnologySWH\\Modules\\Object\\PETAgeCard::getDeckType()";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}