package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z_]+[a-zA-Z0-9_]*`)
var str = `abc
i10n
10abc
abcабвгд
abc.3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}