#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.+)(?:[Ss _\.](\d{2,})[Ee _\.](\d{2,}))[\. _](\d{3,4}p)?(.+)?.*?\-(.+?)(?:\[(.+)\])?\.(\w+)"
Local $sString = "Ridiculousness.S07E15.HDTV.x264-TASTETV[eztv].mp4" & @CRLF & _
                "Portlandia.S06E03.HDTV.x264-KILLERS[eztv].mp4" & @CRLF & _
                "Life.in.Pieces.S01E15.HDTV.x264-KILLERS[eztv].mp4" & @CRLF & _
                "Portlandia.S06E03.720p.HDTV.x264-KILLERS[eztv].mkv" & @CRLF & _
                "Idiotsitter.S01E04.HDTV.x264-KILLERS[eztv].mp4" & @CRLF & _
                "Lip.Sync.Battle.S02E05.720p.HDTV.x264-ALTEREGO[eztv].mkv" & @CRLF & _
                "Lip.Sync.Battle.S02E05.HDTV.x264-ALTEREGO[eztv].mp4" & @CRLF & _
                "Shades.of.Blue.S01E05.720p.HDTV.x264-AVS[eztv].mkv" & @CRLF & _
                "Shades.of.Blue.S01E05.720p.HDTV.x264-FLEET[eztv].mkv" & @CRLF & _
                "Colony.S01E04.720p.HDTV.x264-KILLERS[eztv].mkv" & @CRLF & _
                "Shades.of.Blue.S01E05.HDTV.x264-FLEET[eztv].mp4" & @CRLF & _
                "Baskets.S01E03.INTERNAL.720p.HDTV.x264-KILLERS[eztv].mkv" & @CRLF & _
                "Baskets.S01E03.INTERNAL.HDTV.x264-KILLERS[eztv].mp4" & @CRLF & _
                "Workaholics.S06E04.720p.HDTV.x264-KILLERS[eztv].mkv" & @CRLF & _
                "Baskets.S01E03.HDTV.x264-FLEET[eztv].mp4" & @CRLF & _
                "Baskets.S01E03.720p.HDTV.x264-FLEET[eztv].mkv" & @CRLF & _
                "The.Blacklist.S03E13.720p.HDTV.x264-AVS[eztv].mkv" & @CRLF & _
                "The.100.S03E03.720p.HDTV.x264-AVS[eztv].mkv" & @CRLF & _
                "Angel.From.Hell.S01E05.HDTV.x264-LOL[eztv].mp4" & @CRLF & _
                "Angel.From.Hell.S01E05.720p.HDTV.X264-DIMENSION[eztv].mkv" & @CRLF & _
                "The.100.S03E03.HDTV.x264-FLEET[eztv].mp4" & @CRLF & _
                "Mom.S03E10.HDTV.x264-LOL[eztv].mp4" & @CRLF & _
                "Mom.S03E10.720p.HDTV.X264-DIMENSION[eztv].mkv" & @CRLF & _
                "Life.in.Pieces.S01E15.720p.HDTV.x264-AVS[eztv].mkv" & @CRLF & _
                "Elementary.S04E11.HDTV.x264-LOL[eztv].mp4" & @CRLF & _
                "Elementary.S04E11.720p.HDTV.X264-DIMENSION[eztv].mkv" & @CRLF & _
                "DCs.Legends.of.Tomorrow.S01E03.HDTV.x264-LOL[eztv].mp4" & @CRLF & _
                "The.Vampire.Diaries.S07E11.HDTV.x264-LOL[eztv].mp4" & @CRLF & _
                "DCs.Legends.of.Tomorrow.S01E03.720p.HDTV.X264-DIMENSION[eztv].mkv" & @CRLF & _
                "The.Vampire.Diaries.S07E11.720p.HDTV.X264-DIMENSION[eztv].mkv" & @CRLF & _
                "Saving.Hope.S04E16.HDTV.x264-BAJSKORV[eztv].mp4" & @CRLF & _
                "Saving.Hope.S04E16.720p.HDTV.x264-BAJSKORV[eztv].mkv" & @CRLF & _
                "The.Big.Bang.Theory.S09E14.HDTV.x264-LOL[eztv].mp4" & @CRLF & _
                "The.Ellen.DeGeneres.Show.2016.02.04.HDTV.x264-ALTEREGO[eztv].mp4" & @CRLF & _
                "The.Ellen.DeGeneres.Show.2016.02.04.720p.HDTV.x264-ALTEREGO[eztv].mkv" & @CRLF & _
                "Teachers.2016.S01E04.REPACK.720p.HDTV.x264-ALTEREGO[eztv].mkv" & @CRLF & _
                "Celebrity.Big.Brothers.Bit.On.The.Side.S10E24.720p.HDTV.x264-C4TV[eztv].mkv" & @CRLF & _
                "Long.Island.Medium.S07E03.HDTV.x264-CRiMSON[eztv].mp4" & @CRLF & _
                "Celebrity.Big.Brothers.Bit.On.The.Side.S10E24.HDTV.x264-C4TV[eztv].mp4" & @CRLF & _
                "Clarence.US.S02E06.Time.Crimes.720p.HDTV.x264-W4F[eztv].mkv" & @CRLF & _
                "Clarence.US.S02E06.Time.Crimes.HDTV.x264-W4F[eztv].mp4" & @CRLF & _
                "Clarence.US.S02E05.Ren.Faire.720p.HDTV.x264-W4F[eztv].mkv" & @CRLF & _
                "Clarence.US.S02E05.Ren.Faire.HDTV.x264-W4F[eztv].mp4" & @CRLF & _
                "Great.British.Railway.Journeys.Series.7.05of20.Ashley.to.Alton.720p.x264.HDTV[eztv].mp4" & @CRLF & _
                "Celebrity.Big.Brother.S17E35.HDTV.x264-C4TV[eztv].mp4" & @CRLF & _
                "James.Corden.2016.02.03.Rosie.ODonnell.HDTV.x264-TASTETV[eztv].mp4" & @CRLF & _
                "James.Corden.2016.02.03.Rosie.ODonnell.720p.HDTV.x264-TASTETV[eztv].mkv" & @CRLF & _
                "Mr Robot S01E10 2015 HDTV x264 - SPARKS.wmv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")