$re = '/(^|\s|>)#([^\s<>\/]+)($|\s|<)/i';
$str = 'https://domain.com/x#fragment
#***
nota#hashtag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);