$re = '/\(*\d\)\)/m';
$str = ' //
this->m_rButtonNewModule->Anchor = static_cast<System::Windows::Forms::AnchorStyles>((System::Windows::Forms::AnchorStyles::Top | System::Windows::Forms::AnchorStyles::Right));
this->m_rButtonNewModule->Location = System::Drawing::Point(463, (103));
this->m_rButtonNewModule->Name = L"m_rButtonNewModule";
this->m_rButtonNewModule->Size = System::Drawing::Size(88, 23);
this->m_rButtonNewModule->TabIndex = 4;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);