$re = '/^.*?\bwww.deindesign.de\/de\/designer\b.*?\workspace\b.*?$/m';
$str = 'https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/162674402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/house/101149226/162674402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/peter/101149226/162674402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/162688402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732168/
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732163/
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732162/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);