#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\/\*(.|\n|\r)*\*\/"
Local $sString = "" & @CRLF & _
"package es.elcorteingles.ns.integrations.schema.omnistoreordernotification._2_0;" & @CRLF & _
"" & @CRLF & _
"import javax.xml.bind.annotation.XmlAccessType;" & @CRLF & _
"import javax.xml.bind.annotation.XmlAccessorType;" & @CRLF & _
"import javax.xml.bind.annotation.XmlType;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" * Contiene informacion del coste a nivel de" & @CRLF & _
" * ShippingGroup." & @CRLF & _
" * - Importe total." & @CRLF & _
" * - Importe pendiente a cobrar." & @CRLF & _
" * - Importe" & @CRLF & _
" * del gasto de envÃo" & @CRLF & _
" * " & @CRLF & _
" * " & @CRLF & _
" * <p>Java class for ShippingGroupPriceInfoType complex type." & @CRLF & _
" * " & @CRLF & _
" * <p>The following schema fragment specifies the expected content contained within this class." & @CRLF & _
" * " & @CRLF & _
" * <pre>" & @CRLF & _
" * <complexType name="ShippingGroupPriceInfoType">" & @CRLF & _
" * <complexContent>" & @CRLF & _
" * <restriction base="{http://www.w3.org/2001/XMLSchema}anyType">" & @CRLF & _
" * <sequence>" & @CRLF & _
" * <element name="totalCost" type="{http://www.elcorteingles.es/ns/integrations/schema/OmniStoreOrderNotification/2_0}AmountType" minOccurs="0"/>" & @CRLF & _
" * <element name="pendingCost" type="{http://www.elcorteingles.es/ns/integrations/schema/OmniStoreOrderNotification/2_0}AmountType" minOccurs="0"/>" & @CRLF & _
" * <element name="shippingCost" type="{http://www.elcorteingles.es/ns/integrations/schema/OmniStoreOrderNotification/2_0}AmountType" minOccurs="0"/>" & @CRLF & _
" * <element name="groupDiscountsAmount" type="{http://www.elcorteingles.es/ns/integrations/schema/OmniStoreOrderNotification/2_0}AmountType" minOccurs="0"/>" & @CRLF & _
" * <element name="totalNetAmount" type="{http://www.elcorteingles.es/ns/integrations/schema/OmniStoreOrderNotification/2_0}AmountType" minOccurs="0"/>" & @CRLF & _
" * </sequence>" & @CRLF & _
" * </restriction>" & @CRLF & _
" * </complexContent>" & @CRLF & _
" * </complexType>" & @CRLF & _
" * </pre>" & @CRLF & _
" * " & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
"@XmlAccessorType(XmlAccessType.FIELD)" & @CRLF & _
"@XmlType(name = "ShippingGroupPriceInfoType", propOrder = {" & @CRLF & _
" "totalCost"," & @CRLF & _
" "pendingCost"," & @CRLF & _
" "shippingCost"," & @CRLF & _
" "groupDiscountsAmount"," & @CRLF & _
" "totalNetAmount"" & @CRLF & _
"})" & @CRLF & _
"public class ShippingGroupPriceInfoType {" & @CRLF & _
"" & @CRLF & _
" protected AmountType totalCost;" & @CRLF & _
" protected AmountType pendingCost;" & @CRLF & _
" protected AmountType shippingCost;" & @CRLF & _
" protected AmountType groupDiscountsAmount;" & @CRLF & _
" protected AmountType totalNetAmount;" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * Gets the value of the totalCost property." & @CRLF & _
" * " & @CRLF & _
" * @return" & @CRLF & _
" * possible object is" & @CRLF & _
" * {@link AmountType }" & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
" public AmountType getTotalCost() {" & @CRLF & _
" return totalCost;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * Sets the value of the totalCost property." & @CRLF & _
" * " & @CRLF & _
" * @param value" & @CRLF & _
" * allowed object is" & @CRLF & _
" * {@link AmountType }" & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
" public void setTotalCost(AmountType value) {" & @CRLF & _
" this.totalCost = value;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * Gets the value of the pendingCost property." & @CRLF & _
" * " & @CRLF & _
" * @return" & @CRLF & _
" * possible object is" & @CRLF & _
" * {@link AmountType }" & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
" public AmountType getPendingCost() {" & @CRLF & _
" return pendingCost;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * Sets the value of the pendingCost property." & @CRLF & _
" * " & @CRLF & _
" * @param value" & @CRLF & _
" * allowed object is" & @CRLF & _
" * {@link AmountType }" & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
" public void setPendingCost(AmountType value) {" & @CRLF & _
" this.pendingCost = value;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * Gets the value of the shippingCost property." & @CRLF & _
" * " & @CRLF & _
" * @return" & @CRLF & _
" * possible object is" & @CRLF & _
" * {@link AmountType }" & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
" public AmountType getShippingCost() {" & @CRLF & _
" return shippingCost;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * Sets the value of the shippingCost property." & @CRLF & _
" * " & @CRLF & _
" * @param value" & @CRLF & _
" * allowed object is" & @CRLF & _
" * {@link AmountType }" & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
" public void setShippingCost(AmountType value) {" & @CRLF & _
" this.shippingCost = value;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * Gets the value of the groupDiscountsAmount property." & @CRLF & _
" * " & @CRLF & _
" * @return" & @CRLF & _
" * possible object is" & @CRLF & _
" * {@link AmountType }" & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
" public AmountType getGroupDiscountsAmount() {" & @CRLF & _
" return groupDiscountsAmount;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * Sets the value of the groupDiscountsAmount property." & @CRLF & _
" * " & @CRLF & _
" * @param value" & @CRLF & _
" * allowed object is" & @CRLF & _
" * {@link AmountType }" & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
" public void setGroupDiscountsAmount(AmountType value) {" & @CRLF & _
" this.groupDiscountsAmount = value;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * Gets the value of the totalNetAmount property." & @CRLF & _
" * " & @CRLF & _
" * @return" & @CRLF & _
" * possible object is" & @CRLF & _
" * {@link AmountType }" & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
" public AmountType getTotalNetAmount() {" & @CRLF & _
" return totalNetAmount;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * Sets the value of the totalNetAmount property." & @CRLF & _
" * " & @CRLF & _
" * @param value" & @CRLF & _
" * allowed object is" & @CRLF & _
" * {@link AmountType }" & @CRLF & _
" * " & @CRLF & _
" */" & @CRLF & _
" public void setTotalNetAmount(AmountType value) {" & @CRLF & _
" this.totalNetAmount = value;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)