$re = '~\bdog\b(?!(?:[^"]*"[^"]*")*[^"]*"[^"]*$)~i';
$str = 'Dog sighed. "I\'m no super dog, nor special dog," said Dog, "I\'m an ordinary dog, now leave me alone!" Dog pushed him away and made his way to the other dog.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);