import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Hagestein boven.+?(?:<td>Waterhoogte<\\/td><td>)(.\\d*)";
final String string = ">H10</td><td><a target=\"_blank\" href = \"http://www.rws.nl/images/GRAVBVN_tcm174-335817.pdf\">meer</a></td></tr><tr><td><a href='awd.php?mode=html&projecttype=waterstanden&category=1&loc=GREB&net=LMW'>Grebbe</a></td><td>21/04 17:30</td><td>Waterhoogte</td><td>643</td><td>cm NAP</td><td>LMW</td><td>GREB</td><td>H10</td><td></td></tr><tr><td><a href='awd.php?mode=html&projecttype=waterstanden&category=1&loc=GREV&net=LMW'>Grevenbicht</a></td><td>21/04 17:30</td><td>Waterhoogte</td><td>2623</td><td>cm NAP</td><td>LMW</td><td>GREV</td><td>H10</td><td><a target=\"_blank\" href = \"http://www.rws.nl/images/GREVBT_tcm174-335691.pdf\">meer</a></td></tr><tr><td><a href='awd.php?mode=html&projecttype=waterstanden&category=1&loc=GRPO&net=LMW'>Groene Riv Pannerden ben</a></td><td>21/04 17:30</td><td>Waterhoogte</td><td>1143</td><td>cm NAP</td><td>LMW</td><td>GRPO</td><td>H10</td><td></td></tr><tr><td><a href='awd.php?mode=html&projecttype=waterstanden&category=1&loc=GRPB&net=LMW'>Groene Riv Pannerden bov</a></td><td>21/04 17:30</td><td>Waterhoogte</td><td>1153</td><td>cm NAP</td><td>LMW</td><td>GRPB</td><td>H10</td><td></td></tr><tr><td><a href='awd.php?mode=html&projecttype=waterstanden&category=1&loc=HAAN&net=LMW'>Haandrik Kruisbrug</a></td><td>21/04 17:30</td><td>Waterhoogte</td><td>910</td><td>cm NAP</td><td>LMW</td><td>HAAN</td><td>H10</td><td></td></tr><tr><td><a href='awd.php?mode=html&projecttype=waterstanden&category=1&loc=HAGO&net=LMW'>Hagestein beneden</a></td><td>21/04 17:30</td><td>Waterhoogte</td><td>98</td><td>cm NAP</td><td>LMW</td><td>HAGO</td><td>H10</td><td><a target=\"_blank\" href = \"http://www.rws.nl/images/HAGSBNDN_tcm174-335693.pdf\">meer</a></td></tr><tr><td><a href='awd.php?mode=html&projecttype=waterstanden&category=1&loc=HAGB&net=LMW'>Hagestein boven</a></td><td>21/04 17:30</td><td>Waterhoogte</td><td>272</td><td>cm NAP</td><td>LMW</td><td>HAGB</td><td>H10</td><td><a target=\"_blank\" href = \"http://www.rws.nl/images/HAGSBVN_tcm174-335697.pdf\">meer</a></td></tr><tr><td><a href='awd.php?mode=html&projecttype=waterstanden&category=1&loc=HANS&net=LMW'>Hansweert</a></td><td>21/04 17:30</td><td>Waterhoogte</td><td>180</td><td>cm NAP</td><td>LMW</td><td>HANS</td><td>H10</td><td><a target=\"_blank\" href = \"http://www.rws.nl/images/HANSWT_tcm174-335699.pdf\">meer</a></td></tr><tr><td><a href='awd.php?mode=html&projecttype=waterstanden&category=1&loc=HAWIb&net=LMW'>Hansweert wind (b)</a></td><td>21/04 17:30</td><td>Waterhoogte</td><td>179</td><td>cm NAP</td><td>LMW</td><td>HAWIb</td><td>H10</td><td></td></tr><tr><td><a href='awd.php?m";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}