$re = '/^\s*\S+\s+\S+\s*$/m';
$str = 'Два слова
Тут три слова
А тут четыре слова
Два слова
Одно';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);