import re
regex = re.compile(r"<a.+?\s*href\s*=\s*[\"\']?([^\"\'\s>]+)[\"\']\s*title=[\"\'](\w+)[\"\']\s*[>](\w*)[<]?", flags=re.IGNORECASE)
test_str = ("<a href=\"/test\" title=\"da\">test</a>\n"
"<a href=\"/test2\" title=\"adwa\">test2</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")