re = /^abc(?:(?!abc).)*abc$/m
str = 'abc..................abc
ab..............abc..............abc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end