$re = '/\/promotions\/catdance-festival-[0-9]{4}\/play/';
$str = 'http://local.wp.freshstep.com/promotions/catdance-festival-2015/play/hover-cat/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);