re = /(?<=,\s|^)(?!\s*\w+=\w+(?=,|$))([^,\n]+)/m
str = 'A=B, C, E=F
A=, C=D,
A=B, C=D, E=F X
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end