#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:"[^"]*"[^"]*?\K|(*SKIP))+(?(DEFINE)(?'d'd{1,4}|m{1,4}|y{2,4}))(?<![dmy.])((?P>d))\.(?!\2)((?P>d))(?:\.(?!\2|\3)((?P>d)))?(?!\.?[dmy])"
Local $sString = ""DD.MM": DD.MM" & @CRLF & _
""DD.MM.YY": DD.MM.YY" & @CRLF & _
""Форматы внутри строки в кавычках DD.MM.YYYY не учитывать": DD.MM.YYYY "и тут dd.mm тоже"" & @CRLF & _
""Поход: " DD.MM. ", кино:" DD.mm" & @CRLF & _
""Datum kann in der Mitte sein" DD.MM.YYYY "oder sogar an Ende" DD.MM.YY" & @CRLF & _
"Форматы без разделителя DDMMYYYY не учитывать" & @CRLF & _
""DD.MM"" & @CRLF & _
"DD.MM" & @CRLF & _
"DD.MM.DD" & @CRLF & _
"DD.MM" & @CRLF & _
""DD.MM"" & @CRLF & _
"DD.MM.DD" & @CRLF & _
"DD.DD.MM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")