package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^,\s]+|,`)
var str = `APPLE,ORANGE CHERRY APPLE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}