re = /".*\s(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\s\d+?\s\d+?\s/
str = '# Bluecoat UPSTREAM Logs
2016-08-31 00:02:54 18 172.25.21.173 - - - OBSERVED "Non-Viewable/Infrastructure" - 200 TCP_HIT GET application/ocsp-response http sr.symcd.com 80 /MFYwVKADAgEAME0wSzBJMAkGBSsOAwIaBQAEFHQkFGcGn%2FXgmD9ePhproGUqVBV1BBQBWavn3ToLWaZkY9bPIAdX1ZHnagIQUufCRVii4D52%2B1NnK%2BL%2Fmg%3D%3D - - "ocspd/1.0.3" 10.222.157.10 1957 316 -
2016-08-31 00:02:54 18 172.25.19.32 - - policy_denied DENIED "Chat (IM)/SMS;Content Servers" http://im.qq.com/mobileqq 403 TCP_DENIED GET - http 203.205.144.22 80 /gchatpic_new/99787480/2125162524-3194779440-DD292643C193D85264F13026ED37A996/198 ?vuin=15929133&term=3&pictype=1003&cldver=6.5.0.443&rf=aio&msgTime=1472601651 - "QQ/6.5.0.443 CFNetwork/758.3.15 Darwin/15.4.0" 10.222.157.10 1185 421 -
2016-08-31 00:02:54 199 172.25.26.70 - - - OBSERVED "Technology/Internet" - 200 TCP_NC_MISS POST application/json;charset=utf-8 http d.applovin.com 80 /device ?device_token=MaznYs97JTiqaqEwnZGZ5u0SoeBtsuRonBn0BJmm3q8hGZZkZ8TWjSHReUJMpRCoo6knaop8PaTY2Hg-vnNcBg34k9zTsGFYDOM6zvxdBDIykMF76uM-xuc_Km4oV6e5uf6-S_X6wDyE1kpriXzu5FBhmSNn4-E-PXKNuJvyqQM= - "Dalvik/1.6.0 (Linux; U; Android 4.4.2; HTC One_E8 Build/KOT49H)" 10.222.157.10 791 1227 -'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end