package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([wow]*)`)
var str = `wow its cool`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}