using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(http(s?):\/\/)?(((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))|([a-zA-Z0-9\-\_]+(\.[a-zA-Z]{2,3})))+(\/[a-zA-Z0-9\_\-\s\.\/\?\%\#\&\=]*)?\.xml$";
string input = @"http://asdf3234.com.es/aasdf/asdf/dsfg.xml";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}