#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "ERROR ([^:]+): (.*)"
Local $sString = "ERROR java.lang.NullPointerException: Sample Java Logback Exception" & @CRLF & _
"" & @CRLF & _
"at Sample.errorLevel3(Sample.java:35)" & @CRLF & _
"" & @CRLF & _
"at Sample.errorLevel4(Sample.java:34)" & @CRLF & _
"" & @CRLF & _
"at Sample.errorLevel5(Sample.java:30)" & @CRLF & _
"" & @CRLF & _
"at Sample.errorLevel6(Sample.java:3)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")