$re = '/^(?:virtual|static)?\s*(.*?)(?=\s\w+=)/';
$str = 'virtual Foo * const operator= (Bar& b);';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);