using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A$^B";
string input = @"A
B
A
B";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}