re = /^(\/[^\/ ]*)+\/?$/m
str = '/home/user/Documents/foo.log was written
the file /home/user/Documents/foo.log was written
/home/user/Documents/foo.log
/foo.bar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end