$re = '/\s*host:\s*"[^"]+"/m';
$str = 'name:"XYZ" port:5672 host:"server.com"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);