import Foundation
let pattern = #"(?=["'])"([^"\\\n]*(?:\\[\s\S][^"\\\n]*)*)[",.!]|'([^'\\\n]*(?:\\[\s\S][^'\\\n]*)*)[',.!]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"Then", he said, "we go home."
"My dear Lizzy,
"I wish you joy. If you love Mr. Darcy half as well as I do my dear Wickham, you must be very happy. It is a great comfort to have you so rich, and when you have nothing else to do, I hope you will think of us. I am sure Wickham would like a place at court very much, and I do not think we shall have quite money enough to live upon without some help. Any place would do, of about three or four hundred a year; but however, do not speak to Mr. Darcy about it, if you had rather not.
"Yours, etc."
"Hello World"
"Hey!Theererererzffzfzfzfz zfzfbcnhdzxghxhxhxhx"
Hello World!I am "Some random text"
"Hey There! This is Some Text!!!! which does not contain quotes.
"thefbjbbssbjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjcbsjcb cbcslablaffblafblbflabflbfabfalafbalbabfaflaflzbzbhavsjdjdbeblbvsbvskbv"
'Hello!!! This is single quoted example.'
'Hello!!!' This is single quoted example.'Here is the one.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)