import re
regex = re.compile(r"\d+", flags=re.MULTILINE)
test_str = ("7,673,656.87\n"
"427,870.27\n"
"7,401.38\n"
"102,393.11\n"
"2,340,692.03\n"
"2,093,675.04\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)