$re = '/^(push|pop|shift|unshift|reverse|splice|sort|copyWithin|fill)$/mu';
$str = 'sort
push
pushNew
prefill
sortAscending
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);