$re = '/(?<!SP|XD)\(\d+-\d+\)/m';
$str = '(1-3)+XD(4-18):SP(19-36)+(37-96)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);