re = /(?:.*?(Constr1)+){3}.*?((Constr1)+)/
str = 'public class Constr1 { private int a; public Constr1 () { Constr1 Constr1 Constr1 //super(); a = 1; //super(); } }'
# Print the match result
str.match(re) do |match|
puts match.to_s
end