import re
regex = re.compile(r"\s(\w*)Command\.Register\((([\S]*,([^;\n\r])*)+)typeof\((.*)Values\)\);")
test_str = ("public static readonly SimpleCommand ReadTemperatureCommand =\n"
" SimpleCommand.Register(ReadTemperatureCommandId, \"ReadTemperature\", \"showtemp.py\", \"\", 5, typeof(TemperatureListCommandResultProcessor), typeof(TemperatureListDeviceValues));\n\n"
" public static readonly SimpleCommand GetDataType1Command =\n"
" SimpleCommand.Register(\n"
" GetDataType1CommandTypeId,\n"
" \"GetData\",\n"
" \"HttpClient2.py\",\n"
" @\"\"\"/data/ajax.txt?CAN=1&HASH=00200403&TYPE=1\"\" \"\"GET\"\" \"\"\"\"\",\n"
" 5,\n"
" typeof(SunwaysSolarInverterDataType1CommandResultProcessor),\n"
" typeof(SunwaysSolarInverterDeviceValues));\n\n"
"public static readonly ArgumentedCommand UpdateAsyncCommandsCommand =\n"
" ArgumentedCommand.Register(\n"
" UpdateAsyncCommandsCommandId,\n"
" \"UpdateAsyncCommands\",\n"
" \"UpdateAsyncCommands.py\",\n"
" \"\",\n"
" 5,\n"
" UpdateAsyncCommandsCreateArguments,\n"
" new[] { typeof(AsynchronousCommand[]) },\n"
" typeof(UpdateAsyncCommandsCommandResultProcessor),\n"
" typeof(GridboxCommunicationObjectValues));\n\n\n\n"
"public static readonly SimpleDynamicObjectAttribute<bool> AsynchronousCommandsChangedProperty =\n"
" SimpleDynamicObjectAttribute<bool>.Register(\"AsynchronousCommandsChanged\", false, typeof(BusyGridObjectValues), false, false);\n\n"
"public static readonly SimpleDynamicObjectAttribute<string> MailProperty =\n"
" SimpleDynamicObjectAttribute<string>.Register(\"Mail\", typeof(DefaultUserValues));\n\n"
"public static readonly ProtectedSimpleDynamicObjectAttribute<int> PasswordStorageMethodVersionProperty =\n"
" ProtectedSimpleDynamicObjectAttribute<int>.Register(\"PasswordStorageMethodVersion\", 2, typeof(DefaultUserValues));\n\n"
"public static readonly ListSetDynamicObjectAttribute<string> LocalIpNetworksProperty =\n"
" ListSetDynamicObjectAttribute<string>.Register(\"LocalIpNetworks\", typeof(GridboxCommunicationObjectValues));\n\n"
"public static readonly DictionaryDynamicObjectAttribute<Guid, GridObjectTypeContentFilter> ContentFiltersProperty =\n"
" DictionaryDynamicObjectAttribute<Guid, GridObjectTypeContentFilter>.Register(\"ContentFilters\", typeof(DefaultContentFilterValues));\n\n"
" public static readonly StrongGridObjectReference ContentFilterListContentFilterIdProperty =\n"
" StrongGridObjectReference.Register(\"ContentFilterListContentFilterId\", new Guid(\"ce06d088-1b5e-4cab-98d2-b0fd63bc0d5b\"), typeof(ContentFilterValues));\n\n"
" public static readonly GridObjectReference ContentFilterListContentFilterIdProperty =\n"
" GridObjectReference.Register(\"ContentFilterListContentFilterId\", new Guid(\"ce06d088-1b5e-4cab-98d2-b0fd63bc0d5b\"), typeof(ContentFilterValues));\n\n"
" public static readonly GridObjectReference ContentFilterListContentFilterIdProperty =\n"
" GridObjectReference.Register(\"ContentFilterListContentFilterId\", new Guid(\"ce06d088-1b5e-4cab-98d2-b0fd63bc0d5b\"), typeof(ContentFilterValues));\n\n"
"public static readonly GridObjectReferenceList PermissionIdsProperty =\n"
" GridObjectReferenceList.Register(\"PermissionIds\", typeof(DefaultRoleValues));")
subst = "GridObjectModel.Register$1Reference$2($3, $4TypeIdString);"
result = regex.sub(subst, test_str)
if result:
print(result)