$re = '/^.*Ethernet[\d][\/][\d].*$|^\w\d{1,2}$/i';
$str = 'fastEthernet0/4';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);