#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?'protocol'[a-z]{2,}(?=[:])):)?(?:\/\/)?(?:(?'subdomain'(?:[0-9a-z](?![\-\.]))+(?:[0-9a-z\-\.][0-9a-z]+)+?)\.(?'domain'(?:[0-9a-z](?![\-]))+(?:[0-9a-z\-][0-9a-z])\.(?'tld'[a-z]{2,}(?:\.[a-z]{2})?))|(?'ip'(?'segment'[01][0-9][0-9]|2[0-4][0-9]|25[0-5]|[0-9])\.(?&segment)\.(?&segment)\.(?&segment)))(?:\:(?'port'\d+))?(?'path'(?:\/[^\/\?]*?)*)?(?:\?(?'query'[^#]*))?(?:#!?(?'hash'.*))?$"
Local $sString = "ftp://regex101.billy.com.uk:3000/test/blah?hello=blah&#!/blah/blue/green" & @CRLF & _
                "https://192.168.1.1/test/lab"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")