package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*$`)
var str = `TD JD QD KD AD
AD KD QD JD TD
KD TD QD AD JD `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}