import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.*(.).*\\1)(?=.*[A-Z].*[A-Z])(?=.*\\d.*\\d.*\\d)[a-zA-Z0-9]{10}";
final String string = "A1B2c3d4e5\n"
+ "A1B2c3d4ee\n"
+ "A1B2c344e5\n"
+ "A1b2c3d4e5\n"
+ "A1B2cldhe5\n"
+ "A1B2cldhex";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}