$re = '/\B(?=(?:.{4})+$)/';
$str = '4581458245834584';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);